Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 17, 2026 - 07:30 AEST
Scheduled
Scheduled maintenance - some services will be offline.
Posted May 17, 2026 - 07:12 AEST
This scheduled maintenance affected: Autotask to Xero (My Accounting Toolbox), Cloud Depot Web App (platform.clouddepot.com), Recurring Payment Service, and HostedPay.