Payrix outage

Incident Report for Cloud Depot

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 09:10 AEDT

Monitoring

Payrix has resolved the issue we are continuing to monitor
Posted Feb 18, 2025 - 05:19 AEDT

Investigating

Payrix is currently having a major outage which is impacting our ability to process new payments with Payrix.
Posted Feb 18, 2025 - 05:11 AEDT
This incident affected: Recurring Payment Service.