Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 13, 2024 - 07:05 AEST
Scheduled
We will be releasing upgrades to our platform during this time, some features & tasks will be paused whilst we complete this upgrade. And our web app might be offline intermittently.
Posted Jul 11, 2024 - 08:53 AEST
This scheduled maintenance affected: Autotask to Xero (My Accounting Toolbox), Cloud Depot Web App (platform.clouddepot.com), and Recurring Payment Service.