Xero API outage

Incident Report for Cloud Depot

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:12 AEDT

Update

We are starting to see services return to normal the error rates are coming down from the Xero API.
Posted Oct 21, 2025 - 11:54 AEDT

Update

We are still seeing 500 server errors from Xero which is impacting our ability to download new invoices from Xero.

https://status.developer.xero.com/
Posted Oct 21, 2025 - 10:11 AEDT

Update

AWS is still having issues and causing Xero API problems we are seeing increased sync faults. If you encounter a sync fault for no reason please request a resync in our portal.
Posted Oct 21, 2025 - 07:46 AEDT

Update

On Monday, 20th October at 7:05am UTC, Xero experienced a global outage caused by a disruption with AWS. As a result, many Xero connections were disconnected. If you are experiencing issues, please reconnect to Xero before reaching out to support.

We will continue to monitor for the next 12 hours.

https://kb.clouddepot.com/knowledge/connecting-to-xero-oauth-2.0
Posted Oct 20, 2025 - 21:08 AEDT

Monitoring

Services are starting to come back online now.
Posted Oct 20, 2025 - 20:39 AEDT

Update

Xero has identified the issue is with hosting provider AWS. Please see Xero status for further updates.
https://status.xero.com/
Posted Oct 20, 2025 - 18:33 AEDT

Identified

Xero is currently experiencing a global outage affecting the API and related services.
Posted Oct 20, 2025 - 18:27 AEDT
This incident affected: Autotask to Xero (My Accounting Toolbox), Cloud Depot Web App (platform.clouddepot.com), Recurring Payment Service, and HostedPay.