Email delays
Incident Report for Cloud Depot
Resolved
This incident has been resolved
Posted Feb 18, 2020 - 17:50 AEDT
Identified
We have identified the source of the issue some of our emails are delayed sending. Working on rolling out a fix shortly.
Posted Feb 18, 2020 - 16:23 AEDT
Investigating
We are currently investigating email delays via our mail gateway.
Posted Feb 18, 2020 - 14:15 AEDT
This incident affected: platform.clouddepot.com.